Forum rss-feed


Software: Having issues with EigenD and OSX El Capitan Beta

Most Recent

written by: TheTechnobear

so, to get this straight, your using the default pico setup, and the piano works.
if so this, is good news, as it means the runtime, eigend and samples are all installed correctly :)

it sounds like your saying you cannot find any audio units, correct?

try to do a plugin scan...
start eigend
tools/plugin scanner
and click on 'full scan'

do you get any errors?
are you plugins listed as 'good plugins'

note: there will no doubt be failed plugins, this is because currently eigend does not support 64 bit plugins, so any 64 bits plugs will be 'failed'

now restart eigend

you will need to start the Tools/EigenBrowser.
- then select the VST instrument on the pico , then select browse
the pico reference guide details which buttons to press to do this, I cant remember off-hand.
the alternative is (still need eigenbrowser running) is to launch Stage, and then go to the VST tab, and select browse there.

you should get a list of both VSTs and Audio units that you have installed.
(assuming you have installed some VSTS/AU! :))

now, there is currently a bit of a gitch in the EigenBrowser UI, so when you select thing, you might have to move the window for it to update.
(Ive got a fix for this, but not got around to building/releasing it yet)

another option, and I think one many of use use, is not to use EigenBrowser, but instead use Workbench.
(this is more advanced!)

to do this, run eigenD , load the default setup and then start workbench.
then look for the audio unit rig 1 (its on the right hand side), click on open
which shows you how a audio unit rig is built.
now... you will find an 'instrument audio unit' component
right click to select the edit tool, then click on the audio unit component
now you will find a parameter call plugin... with browse next to it.
this brings a tree of all available plugins... select the one you want.

I know workbench, seem intimidating at first ... think of its as a modular synth with modules wired up.
BUT in the long run its worth getting to know it, its actually pretty easy to use, and allows for alot of customisation and tweaking.
(and the UI is much more modern than the old EigenBrowser and EigenCommander ones)

tip: when you have selected the VSTs you want to use, you can save the setup, as a user setup.

hope the above helps, if you get stuck let us know, and we can clear up any confusion.

written by: geert

Wed, 26 Aug 2015 09:34:42 +0100 BST

Here are two packages that should work on El Capitan, but I haven't tested since I can't spare a machine at the moment to install the beta. Everything is now installed into /usr/local/pi and the Python version has been updated to the latest in the v2 series. Install the runtime package first and then EigenD.

This version also contains the latest version of Juce, which should improve plugin compatibility and has fixes for MIDI channel rotation in Poly mode so that a channel is reused as late as possible to preserve release trails as long as possible.

I haven't created the resources packages yet for the soundfonts, drum loops, impulses, ... but you should be able to just copy these from the old /usr/pi folder.

Please let me know how this goes.

written by: dggontan

Mon, 31 Aug 2015 18:42:45 +0100 BST

Hello geert,

I have just taste the installation and it works perfectly! thanks very much for your help! I haven tried all functionalities or even connected the Pico yet but will spend more time as soon as I can and report any issues.

Again, thanks a lot for this.

Best Regards,


written by: filulilu

Fri, 2 Oct 2015 13:20:43 +0100 BST

EigenD doesn't work in my Mac too. I installed El Capitan (the official release) and EigenD does not open, its icon has the "forbidden" symbol on it. I installed EigenD pro 2.1.1 that Geert posted above. This version opens but it behaves as if no basestation is connected to the computer.


written by: john

Fri, 2 Oct 2015 14:27:40 +0100 BST

EigenD does not yet run on El Capitan. Apple have made some significant changes to the security arrangements on OSX that have prevented it from doing so. There is some work going on in the developer community (I think Mark and Geert have been looking at it) to enable EigenD to run on El Capitan, but there is no timescale on that at the moment and due to the nature of the changes Apple have made it is fiddly work. I'm sure there will be an announcement here when a new release is available, in the meantime we strongly suggest that you stick to Yosemite for now.


written by: TheTechnobear

Sat, 3 Oct 2015 10:23:16 +0100 BST

can you confirm you installed both the runtime and pro package above, and they both installed correctly.

also, did you have this working on 10.10 before? if not, id do all the normal things like try different ports/cables etc.

is it just the basestation not being found... i.e. does the UI start up?
what colour are the lights on the basestation and alpha/tau?

the fix, is really about moving things around due to 10.11... and I have this version installed on 10.10.
I like others can't afford to upgrade my machine for testing, since there are lots of apps/au's still not working on 10.11 (NI/Steinberg to name just two are not supporting 10.11 yet!) ... but the above should work.
(not sure if Geert has a 10.11 machine.

can you run EigenD on the command line, and see if any errors (see previous page)


written by: geert

Sat, 3 Oct 2015 10:41:56 +0100 BST

I have El Capitan installed now and it does indeed seem that the basestation is not detected even though it's connected. I'll try to find some time in the coming days to take a closer look. I know some of the IOKit lower-level USB functions have changes since I have to rewrite part of the LinnStrument updater, maybe the Eigenharp detection routines are subject to similar problems.

written by: TheTechnobear

Sat, 3 Oct 2015 14:10:51 +0100 BST

give me a shout Geert if you need a hand... I'm pretty familiar with that code as I ported it a few times :)
I possibly could update my MBP to 10.11 to take a look...

ah... just read that daniel did not connect the pico ( I misread that he had it working!)

it would be good to know where its failing.... have you seen if its loaded the firmware?

written by: Mumriken

Sun, 4 Oct 2015 14:33:16 +0100 BST

I got the EigenD from the install above (2.1.1 Experimental) running. It does recognise the MIDI-signals now, but I still have to move the old soundfonts into the new directorey. But so far, you have saved my work for the next week, Geert! Thank you so much for the effort you put into this!!

Best regards,


written by: TheTechnobear

Sun, 4 Oct 2015 15:48:08 +0100 BST

@mumriken... so you have an eigenharp running on 10.11 ... pico/tau/alpha?

written by: TheTechnobear

Sun, 4 Oct 2015 21:51:30 +0100 BST

ok, so Ive taken the plunge, and upgraded my MPB to 10.11, to see whats going on.

this is what I have worked out so far:

if you upgrade to 10.11 if will delete /usr/pi i.e. your previous install is gone.
(I know i was surprised too... it appears apple want /usr clean !)
EDIT: found it, it gets moved to /Library/SystemMigration/History/xxxx/QuarantineRoot/usr

so I then installed the runtime and eigenD from above post... installation no problem.

with this I get the following:

a) Pico appears and works (as far as i have tested) BUT when you exit EigenD (I assume when its closing the device) , you get a kernel panic, and the whole machine reboots - arghh!!!
Id regard this as a critical issue

b) Alpha (=basestation) , the alpha keyboard does not show, and so does not work at all

I then built EigenD from source, to start isolating the issue... and ensure i have the latest code.

Ive so far determined....
It is not device enumeration, the base station is correctly found, and the firmware is correctly loaded.
(tests seem to indicate that the firmware is correctly uploaded to the BSP and is operating)
at the moment, the indication is its pipe starvation (on iso pipes) which causes the keyboard to close, and so shutdown the usb device.

I need to do further tests to determine if the pipe starvation is 'real', or if eigenD is being over eager...
Ive seen initialisation timing issues in the past, and this might also explain why the pico works.

of course the concern is, fixing the alpha issue, will probably just mean we will then see the Pico issue, as the code is pretty much the same.

Geert do you have anything to add?, is this consistent with your findings?

EDIT: original tests were done on 10.11. Ive just tried updating to 10.11.1 (BETA) and exactly the same issues exist. (i.e. 10.11.1 does not look like it will resolve issues)

EDIT2: the above are the 'main' issues, there are also UI issues, and I think other issues with some VSTs

EDIT3: disabling SIP solves neither of the USB issues.

written by: Mumriken

Mon, 5 Oct 2015 02:06:01 +0100 BST

@The techno bear it's a Tau, forgot to say that...

Yes, I installed the new EigenD version from the Dropbox share above and it seems to work (if not yet well) with my tau. I have not moved the sound fonts etc yet, but with the info in your last post I will try to relocate them today.

The MIDI controllers work fine again so I can play music again. However, it rescanned the vsts but I can't select them in the eigenbrowser now. I will have to check if I did that part right again today.

PS I seem to have reported some "abuse" in this thread due to writing on a phone. I am very sorry about this unfortunate mistap!

written by: geert

Mon, 5 Oct 2015 10:14:41 +0100 BST

FYI I figured out the problem with the basestation not showing up, and thus the Alpha/Tau not being usable. Doing some final tests, then I'll build a new release to test.

written by: TheTechnobear

Mon, 5 Oct 2015 11:09:43 +0100 BST

@Geert - cool!
Ive not got a lot of time, but will try to find some time later today to test your changes.

btw.have you experienced the kernel panic when EigenD exits? either with the pico or alpha?

also the UI issues with VSTs, is this new?

I ask as its the first time Ive used EigenD on the MBP which has a retina display... rather than my iMac which doesn't, so I'm wondering if it could be related to that, rather than the newer juce/el capitan.

written by: geert

Mon, 5 Oct 2015 11:51:54 +0100 BST

Here is a new package for the EigenD installer that should properly detect the Alpha/Tau basestation:

@Mark I do indeed get a kernel panic when EigenD quits with the Pico active, the Alpha and Tau work fine.

Many AU/VST plugins have trouble on El Capitan, I haven't really had the time to look at them yet. They used to work fine on Yosemite though on my MBP retina.

written by: TheTechnobear

Mon, 5 Oct 2015 14:27:53 +0100 BST

cool, changes seem to work for me for the Alpha :)

pico, some more info:
- if you load a setup (so pico manager) and the pico pico is already plugged in, seems to make the keyboard die immediately. if you plug in the pico after pico manager has started it (usually) works ok.
BUT, I have a feeling this may have been the case with 2.1 prior to 10.11, as I remember having to unplug the pico and plug it back in, in the past.

- kernel panic does NOT happen if you unplug the pico before you exit eigenD.

I tried commenting out the shutdown hook (the obvious culprit) but that didn't help, so just need to work through closing sequence to determine whats triggering the panic.
(Im assuming either a request sent out, or an IOcompletion event perhaps coming in after its been partially shutdown)

written by: TheTechnobear

Mon, 5 Oct 2015 18:23:57 +0100 BST

ok, Ive checked in a change which resolves the kernel panic on the pico.

its not quite clear exactly what has changed...its some kind of timing of the closing of the usb device/interface at shutdown, but Im finding it difficult to get any tracing (even using fprintf(stderr)) before the panic occurs... but stopping the pipes and closing device in shutdown handler resolves the issue.

generally, Im finding the pico initialisation is also a bit 'hit n miss', I quite often get not responding errors (kIOReturnNotResponding ) when plugging it in. not sure if this is new though, will have to cross check with 10.10

written by: TheTechnobear

Tue, 6 Oct 2015 12:03:34 +0100 BST

ok, committed the 'clean' fix for the pico kernel panic.

issue was caused by incorrect pico manager agent implementation, which did not close keyboard correctly on application exit (aka on_quit).
the shutdown handler (atexit) appears to have been added as a 'band aid' fix ( a very long time ago!), rather than dealing with the issue correctly.
Id say el capitan was raising a panic due to a completion message being received, when EigenD was not no longer able to process it properly.

( I reviewed the alpha/tau agent, and that is correctly dealing with the app exit)

(as an aside id say the subsystem implementation in agent could do with a bit of improvement, to ensure when quit happens subsystems are automatically closed, so the derived agents don't have to implement this code)

this along with Geert's fix seems to make eigenD stable, but there are severe UI issues for the VSTs, so I would still not recommend using at this time.

written by: geert

Tue, 6 Oct 2015 12:29:20 +0100 BST

Great work Mark, I uploaded a new experimental build with that fix in also:

When I find more time I'll start packaging this release up and put it on the main website.

written by: Mumriken

Thu, 8 Oct 2015 20:05:13 +0100 BST

Is anyone else having problems opening the EigenBrowser with the experimental version?

When I try to browse the VST Plugins from the Stage program, the EigenBrowser does not open at all. Do I need to reinstall something to make it work again?

written by: TheTechnobear

Fri, 9 Oct 2015 11:34:56 +0100 BST

@geert there appears to be something with packaging...

EigenD when build from source, and run from the build (tmp/app) works fine, EigenBrowser etc.

BUT if you package it, and then install it, it appears to have multiple problems loading things. EigenBrowser/Commander are the obvious ones , but also if you run the command line you will find its not loading the pico correctly either...

eigend-backend: ImportError: dlopen(/usr/local/pi/release-2.1.1-experimental/modules/, 2): Library not loaded: @executable_path/libpico_decoder_1_0_0.dylib
Referenced from: /usr/local/pi/release-2.1.1-experimental/bin/libpico.dylib

as far as I can tell the files are there.

note: this happens on both the package you built, and also if I build the package myself.

note2: this is NEW, the last test build you did works fine... so I suspect its due to the recent changes you made to darwin tool regarding signing.

Please log in to join the discussions