Forum rss-feed

Forum

Software: EigenD 2.1.7 community release (all platforms)

Most Recent

written by: keyman

If you have STAGE running you can activate the Metronome (the Drummer starts playing a drum loop) for AUDIO you can go to EigenD > Windows>Audio Settings (CMD+2) and choose appropriate audio interface/Built-In Output.

Other "Sounds" you have to "manually" copy over:
- sound fonts (for sampler 1, 2, 3
into ~user/Library/Eigenlabs/Soundfont

- ImpulseResponse for Cello/Clarinet
into ~user/Library/Eigenlabs/ImpulseResponse

- All user Loops:
into ~user/Library/Eigenlabs/Loop

written by: TheTechnobear

Thu, 8 Dec 2016 17:13:48 +0000 GMT

New EigenD release (2.1.7) now available for macOS 32 &64 bit, Win32, Linux 64bit, Linux ARM 32bit

UPDATE: windows version updated on 8/12/2016, removes necessity to copy runtime around, instead uses 1.0.0 as before.


TheTechnobear's community 2.1.7 release

associated Eigenharp community google+ post here

Please read included release notes for important information and installation notes.

changes:
- updated to latest Juce framework (4.3.0)
- improved 64 bit support macOS
- fix macOS 32 bit to python from /usr/local/pi
- improved linux build
- fix eigenD hanging on exit
- workbench: select agent menu, pressing letter selects first agent
- updated release notes and introduce install notes into doc.

Enjoy
Mark

p.s. if you download, please say HI here, and let me know which platform your running on
(windows/mac/linux/pi) , its nice to know how many users are out there, and what they are running on.


written by: ivan

Fri, 2 Dec 2016 17:39:29 +0000 GMT

Hi Mark,
Downloaded and installed. EigenD and Workbench don't start. Stage starts. EigenD's icon pops up but in a couple of seconds disappears.
System has 2.1.2 release installed (if it matters).
MBP, macOS Sierra 10.12.1


written by: ivan

Fri, 2 Dec 2016 21:17:51 +0000 GMT

ImportError: No module named site

Perhaps, that's the problem.. But didn't figure out yet how to solve it.


written by: ivan

Fri, 2 Dec 2016 21:56:52 +0000 GMT

ok, python was default one in /System.
downloaded from python.org and got it into /Library.
now all starts and working.
Thanks!


written by: earthspot

Fri, 2 Dec 2016 23:35:35 +0000 GMT

Hi Mark,
You ask (on Google+) to know who's still interested in this.
…I am, though not installed yet. Will do as soon as I find time.

Platform: iMac, El Capitan.


written by: TheTechnobear

Sat, 3 Dec 2016 09:55:11 +0000 GMT

@ivan , this sounds very much like incorrect installation of the the mac 64bit version?

if so the installation instructions (in release notes) cover this.

as stated, users should read the release notes, it includes important information.


written by: ivan

Sat, 3 Dec 2016 12:29:12 +0000 GMT

Yep, 64bit version. I did read the instructions, but thought why would I need two installations of python of same version if I had one already.. but now it is in the right place.
Thanks for the effort Mark!


written by: TheTechnobear

Sat, 3 Dec 2016 12:56:37 +0000 GMT

ivan said:
but thought why would I need two installations of python of same version if I had one already


its a good question, actually its down wanting to push EigenD forward on to the latest python version, initially 2.7.12 (then perhaps 3).

I haven't done this yet, as Ive stumbled on to other issues, with the way Eigenlabs have packaged python and its packages... which means Id need to rebuild these.... but as yet, eigenlabs have not supplied me (open sourced) with the relevant build source code require for the runtime library. so this would require more effort than I have time for at the moment, so thought better to get it out 'as is'.

its an interesting 'area'... If i don't get the necessary files for building the runtime, then Im going to have to decide on the fate of EigenCommander / EigenBrowser, as these are currently 'crippled' due to it... its a horrible/fragile dependancy.


written by: TheTechnobear

Thu, 8 Dec 2016 17:12:40 +0000 GMT

dear windows users ,
Ive updated the win32 version, so that it no longer requires runtime-1.0.1, it uses 1.0.0 like previous versions. Id recommend updating , and then you can delete runtime-1.0.1 to keep things 'tidy'
enjoy
Mark


written by: haydon

Wed, 28 Dec 2016 16:00:30 +0000 GMT

Ummm....feeling somewhat confused and reluctant to take the first purchasing step...
I have a macbook air and have used windows in the past - 3.2 was the first and XP the last. When I look at the software etc requirements, I see that I can't use my macbook - or I don't think I can as it is running OSX 10.11.6 and has only a 1.6 ghz processor. Do I need to spec a standalone machine and if so, where can I get the specs from. I feel the software and system requirements are sparse. Where do I go for advice. Thanks and apologies if this is in the wrong thread. Happy New year


written by: keyman

Thu, 29 Dec 2016 14:05:57 +0000 GMT

Hi Haydon, better post this in a new/fresh thread for a number of reasons ;-)
I will reply there.


written by: viansi

Fri, 3 Feb 2017 10:05:21 +0000 GMT

ข่าวที่น่าทึ่ง


written by: dggontan

Mon, 29 May 2017 18:19:58 +0100 BST

Hello Mark,

Downloaded and running mac 64bit version. Many thanks for taking the time to improve the software and sharing with the community.

Kind Regards,

Daniel


written by: KMac

Mon, 30 Apr 2018 02:46:45 +0100 BST

Hi Mark, attempting to download the software for a new Pico but having problems. The instructions said to start with the DVD it came with, but it won't install. The USB drive it also came with has the same problem. Confused, KMac


written by: keyman

Tue, 1 May 2018 09:45:36 +0100 BST

@KMac
Are you on windows or macosx? You better install this latest community release 2.1.7. above! forget the old stuff.


written by: KMac

Tue, 1 May 2018 16:18:00 +0100 BST

keyman, I'm on MacOS Sierra 10.12.6. I've tried installing the links from above but nothing seems to be going through. I think 4.2 on the release notes explains my problem, but I don't understand what the directions mean.


written by: TheTechnobear

Tue, 1 May 2018 17:07:41 +0100 BST

KMac,

(as your on 10.12.6, you will need community 2.1.7)

what the exact nature of the problem your having is?
what does 'nothing seems to be going thru' mean ?
does it install? and run but you dont get any sounds?

do the pico lights come on at all, when loading the factory setup?

if lights come on, and its just no sound, then yes, the likely cause is you dont have the resources installed, since you will be then missing the samples for the piano sound.
however, the midi rigs should work fine... and its worth testing this.


as for rrelease notes 4.2, yes this is about resources.

the factory installation of EigenD include a lot of samples/loops , and a few VSTs... this is supplied on the DVD you have, or can be downloaded from the EigenD website.
unfortunately, it tries to install to a directory that is not allowed on macOS these days, so the install fails.
this can be overcome,

a) by disabling SIP,

https://www.imore.com/el-capitan-system-integrity-protection-helps-keep-malware-away

b) installing the resources which will not work
c) moving the install files from
/usr/pi/resources to /usr/local/pi/resources

d) re-enabling SIP
(not 100% necessary, but its not a bad idea)


Id like to rebuild the resources disk image, but unfortunately, I dont have access the installer code that was used to build it.
and I also dont have the online disk space to store such a large image.

Note: as such EigenD works without the resources installed, but things like the piano wont sound, because it doesnt have the samples - you could replace the samples and then it works fine.
similarly, MIDI will work without the resources, as its doesnt need them.


written by: KMac

Tue, 1 May 2018 21:56:55 +0100 BST

When I open Mac OS Support from the DVD, the message reads "The installer could not install the software because there was no software found to install."

When I open EigenD 2.0.66 for MacOS X from the USB drive, the message reads "EigenD 2.0.66 can't be installed on this disk. Please install the EigenD Support package before installing EigenD."

When I download EigenD-gpl-2.1.7-community-mac-i386.pkg the message reads "EigenD-gpl-2.1.7-community can't be installed on this disk. Please install the EigenD Support package before installing EigenD."

When I download EigenD-gpl-2.1.7-comminuty-mac-x86_84.pkg the message reads "EigenD-gpl-2.1.7-community can't be installed on this disk. Please install the EigenD Support package before installing EigenD."

When I plug the Pico into my laptop, no lights come on, no programs open, there isn't even an icon like with the DVD or the USB drive. My computer vocabulary is rudimentary, but from what I understand I think option c) moving the install files is the first way I'd like to try. However, I don't understand where the files would be found and where they would be moved to.


written by: TheTechnobear

Wed, 2 May 2018 20:57:40 +0100 BST

You need to install the runtime first
EigenD-Runtime-1.0.1.pkg

Then install 2.1.7


written by: KMac

Fri, 4 May 2018 18:12:19 +0100 BST

My progress so far: I have downloaded runtime and opened Stage and the lights are on, but no sound.



Please log in to join the discussions