Forum rss-feed


Help: OSC to Stage problem

Most Recent

written by: sfellner

The issue with TouchOSC was just fixed today by Version 1.7.1

written by: dkah

Thu, 28 Apr 2011 09:19:37 +0100 BST

I tried this:

natcl said:
For the curious who want to try with an iPhone while the official app isn't out, here's the base layout in TouchOSC:
The outgoing port needs to be set to 55551

around 3 weeks ago and it worked. In the meantime I have the newest EigenD/Stage 1.3.17 and a new TouchOSC did come out and now I cannot get it to work.
So I wrote a little Max/Msp patch to test things, like space vs. underscore and such
screenshot, pressing on the talker7 message with port 55551, which should activate the metronome does nothing. Tested it also on 1.3.16 still nothing. Tried it with and without underscores/spaces still nothing.
What am I doing wrong?
Should maybe mention it, I am on Mac 10.6.

written by: geert

Thu, 28 Apr 2011 10:40:53 +0100 BST


You must have some typos somewhere or something not quite right in your Max/MSP setup. I just tried with Bidule and EigenD 1.3.7, using the address /talker_7/key_1/activate. When I send it one parameter with value 1, it correctly triggers the talker and toggles the metronome. Here's a screenshot of my setup.

Hope this will help you figure things out.

Take care,


written by: sfellner

Thu, 28 Apr 2011 10:59:36 +0100 BST

@dkah: same here

TouchOSC stopped working for EigenD 1.3.17 and TouchOSC 1.7.
Before I could use my TouchOSC layout:

The port EigenD is listening on is easy to detect, in my case it is only 55553:

netstat -a | grep -i "listen"
did run netstat before and while EigenD running and looked for the difference.
I get the same port 55553 for EigenD on two different machines, both OS X 10.6.7

Unfortunately connecting TouchOSC to port 55553 does not work either.

Maybe the fact that there is no port 55551 listening is part of the issue?

written by: dkah

Thu, 28 Apr 2011 11:51:05 +0100 BST

Tried it with 1.3.9 unstable works, with 1.3.17 testing it doesn't.
Had to put a 1 behind the talker message (in max/msp). It behaves funny, probably because I don't know what I am doing, but then it works with the 1.3.9. version on port 55551. But not with the testing version.

PS: Is it possible to get the version number of the running Stage somewhere? Having it visible in the GUI all the time would be very practical for testing and unstable versions.

written by: geert

Thu, 28 Apr 2011 13:22:33 +0100 BST

Unstable versions are just that, no guarantees and unsupported, we change the APIs and features quite a bit before it goes to testing status. In testing we start to stabilize everything and guarantee compatibility between your saved setups from then onwards. So it's totally possible that OSC that used to work in 1.3.9-unstable doesn't work anymore, Stage has undergone quite a bit of work.

What do you mean when you say 'it behaves funny'. It's totally reliable with the OSC messages I send with Bidule. With the Stage desktop and iOS application everything's fine also. The version number of Stage is printed out to the console at startup, I'll see about adding an about window with the version number as for EigenD. We don't plan on making any incompatible changes to Stage in the 1.3 series anymore so you should be fine from now on.



written by: dkah

Thu, 28 Apr 2011 13:01:15 +0100 BST

Further testing:
1.3.14 testing no problem
1.3.16 testing no problem

1.3.17 testing starting metronome works but the first time you start up EigenD and Stage it has a significant delay.

I use max/msp and send the message "/talker_7/key_1/activate 1" -> "udpsend localhost 55551".

written by: sfellner

Thu, 28 Apr 2011 17:38:38 +0100 BST

silly me, got it wrong. of course we are looking for udp.

netstat -a | grep -i "5555"
this gives us udp 55551 and udp 55554-55559
Port tcp 55553 is the xmlrpc server.

calling EigenD 1.3.17 via Processing and OSC works:
oscP5.send("/talker_7/key_1/activate",new Object[] {new Integer("1")}, new NetAddress("",55551));

So I guess there were breaking changes in TouchOSC 1.7.

written by: geert

Thu, 28 Apr 2011 19:22:15 +0100 BST

Seems there are some problems with the latest TouchOSC, Twisted Tools are recommending people not to update:

written by: sfellner

Wed, 4 May 2011 14:31:44 +0100 BST

The issue with TouchOSC was just fixed today by Version 1.7.1

Please log in to join the discussions